Sign In to join the community | Help
Heating & Cooling

Hampton bay ceiling fan lights blinking on and off

Recently my Hampton bay ceiling fan lights started blinking on and off. This happens when I turn the light on at the switch. If I then go to the fan and use the pull chain to turn off the lights and then pull the chain to turn them back on, the come on and stay on. Once the lights are turned off at the switch, the problem comes back. I have two exact same fans on the same light switch but only one of them is having this problem so I don't think that the light switch is having problems.
Not what you were looking for ? Try posting a question
Posted 2011-12-11T15:33:54+0000  by Tcrag Tcrag

Hello Tcrag and thank you for joining The Community.  We are glad that you are here.

 

Our Hampton Bay team can help you diagnose the problems and get things working the way that you want them to work.  Call them at 1-877-527-0313 (option 2) and provide the 12 digit UPC code (all numbers – no letters) found on the sticker on top of the motor housing.  This will identify the exact model and manufacturer of the fan.   They can also help you get the owners manual for your ceiling fan.  Be sure to write the UPC numbers in your manual for future reference. 

 

Best wishes and thank you for joining the discussions.

Posted 2011-12-13T14:14:40+0000  by Eileen_HD_ATL
Hi Torag. What was the outcome? I just installed two of these fans today and one is having this same problem. Will call Hampton bays tomorrow.
Posted 2012-01-23T01:45:00+0000  by Cronk

Hello Cronk and welcome to The Community.  We are glad that you are here. 

 

I was wondering how the call to the Hampton Bay team turned out and hope all is well with your ceiling fans. 

 

Please keep us posted on your progress and best wishes with your fans.

 

dw3.png

Posted 2012-02-28T22:06:11+0000  by Eileen_HD_ATL

Hi,  this problem could by the wall switch.  With the light on go to the switch and wiggle it while moving it up and down.  If the light blinks the wall switch is bad and needs replacing.  Hope this helps.

Posted 2012-03-01T15:01:05+0000  by Stukas

I am now having the same issue with my 60 inch Hampton Bay ceiling fan.

It's worked fine for 5 years but recently went to it and turned it on and the lights just flash.

 

This is a large ceiling fan with two options of lights, one can come on separately (Lower) is just a dome. And the upper comes on also, there are separate buttons for each 'upper and lower lights'  on the remote in green. Both sets of lights flash when I turn the fan on now and the fan does not work.

 

The fan will not turn on any speed and no buttons on the remote work.  It just happened all of a sudden.  I did not read any resolution on the last post With a similar or same issue.

 

I checked that the remote and fan are set on the same transmission band, they are.

 

Any ideas out there are appreciated.

 

Jason

 

Posted 2013-02-05T17:11:31+0000  by JasonFryer1

Hello Jason and welcome to The Community!  We are glad that you are here.

 

I can understand your frustration about the ceiling fan and lights not performing properly after 5 years.  Could you contact the Hampton Bay team to help diagnose these problems and get your ceiling fan working properly again?  They can be reached at 1-877-527-0313 (option 2).  To get to a successful resolution, they will need the 12 digit UPC code (all numbers – no letters) found on the sticker on top of the motor housing to exactly identify the model and manufacturer of your fan.  

 

Best wishes and thank you for joining the discussions.

  

Posted 2013-02-05T20:55:01+0000  by Eileen_HD_ATL

Wow, my 2 year old fan is doing the exact thing for the last 6 months or so. I assume I need to call with the UPC code and will do that tomorrow.  Since this seems to be a recurring problem with lots of people, I was just wondering if anyone had the solution developed and had gotten any satisfaction.

Thanks

Marty_W

Posted 2013-08-25T16:45:39+0000  by Marty_W

Never mind my post, I figured it out finally.... it was the wattage limiter, model 98480X.  I put exactly the same bulbs in it but the limiter must have eiher failed or thought the bulbs were higher wattage.  Problem solved, thanks.

Posted 2013-08-25T17:03:41+0000  by Marty_W

My 60" fan started blinking also, after about 4 years, same bulbs. I removed the wattage limiter and all is good, No more strobe light in the bedroom.  There's nothing I can't fix...with google and you tube!

Posted 2013-08-26T01:58:05+0000  by econbassman

Delete the limiter from the wiring inside the lighting compartment. Reconnect wiring white to white, black to black. Wall switches will work the same.

Posted 2013-11-30T07:48:29+0000  by Calman
Not what you were looking for ? Try posting a question

Topic
Categories+