Sign In to join the community | Help
Tools & Hardware

Ryobi cordless mower won't start.

I've had my mower for 2.5 years. Now it will not start. The battery is fully charged. I think there is a problem with the fuse key not making the connection. I cannot find anyone in the area to service this mower. How do I repair this problem?

Not what you were looking for ? Try posting a question
Posted 2013-07-15T17:49:47+0000  by RepairsNeeded RepairsNeeded
 

Howdy "RepairsNeeded",

 

Welcome to the Home Depot Community. This site is where we exchange information, expertise, and opinions.

 

Depending on where your located, you can find a service center near you with this Ryobi Service Center locations.

 

Let us know if you have more questions,

 

Happy Gardening,

Posted 2013-07-15T23:04:23+0000  by Dave_HD_OC

Thanks for responding. I have already tried that link and found no one to take this machine in my area. I called a bunch of local places too and no luck. I guess I've made my last Ryobi purchase.

Posted 2013-07-16T00:47:35+0000  by RepairsNeeded
I'm sure the original poster has either solved the problem or trashed to mower. So this is for anyone new looking for an answer to this question -- like I was two hours ago.
what looks like a small bulb at the top of the fuse key is actually a reset button. (found this out by accident)
Take the fuse key out to disable the machine
clean any debris that may be blocking the blade and check that nothing has wound itself around the blade shaft (tough long grass, twin, string...)This was my problem.
Change or charge the battery
if if doesn't work with a freshly charged battery 
then try pressing in the reset button on the key. Worked for me! 
Posted 2016-08-31T22:37:05+0000  by nancyjow
Thanks nancyjow for pointing this out!

We welcome any and all input that might help our customers find solutions to their problems. 

Thanks again for sharing your experience,

-Travis
Posted 2016-09-06T14:16:44+0000  by Travis_HD_ATL
Nancyjow - thank you so much!

Fixed my issue.
Posted 2017-05-14T18:33:52+0000  by WSM3
Nancyjow....thank you, thank you, thank you.

The service center I called said it would be 3-4 weeks before they could get to it. Your tip that the bulb looking thingy on the fuse is actually a reset saved me a bunch of headaches.

Thumbs up stranger!
Posted 2017-05-23T22:46:43+0000  by virgil69
I don't have a bulb looking thingy on my fuse key.  Are there any other resets?  My battery is fully charged.


Posted 2018-05-11T16:46:45+0000  by Grechen
 
Not what you were looking for ? Try posting a question

Topic
Categories+