Sign In to join the community | Help
Heating & Cooling

Hampton Bay Ceiling Fan just stopped working after a few weeks

Hi All,

 

I bought a Hampton Bay ceiling fan back in July/August from Home Depot and just had it installed a few weeks ago.  Up until a few days ago it just stopped working.  I believe the ceiling fan is the "Midili 44 in. Indoor Brushed Nickel Ceiling Fan" with the following details:

  Model # 68044 Internet # 100630845 Store SKU # 903913

 

I had two of these fans installed in separate bedrooms and the one in the master bedroom just stopped working.  I do remember dropping the remote and sometime after that it stopped working.  I cannot remember exactly if it worked after dropping the remote or not.  Is this something that could cause it to stop working?  Any way that I can check to see if its not the electrical?  There are no switches on the fan so I don't know if I can just turn it on a different way.  I tried using the other remote but I it didn't work because I guess they are separately programmed.

 

Any help would be appreciated!

Not what you were looking for ? Try posting a question
Posted 2014-01-03T19:28:33+0000  by bjd21 bjd21
 

I actually just switched the frequency on the remote that I thought may be broken to the other fan that still works and the remote works fine so it seems it is something more major.

Posted 2014-01-03T20:18:39+0000  by bjd21

BJD21,

Thanks for reaching out about this. Our technical support can definitely troubleshoot the issues with you over the phone & order any parts if the troubleshooting doesn't resolve.

Please locate the 12 digit UPC from either the sticker on the top of the fan motor (picture attached), or from your instruction booklet, and give the team a call at 800-330-3267.

Thanks very much!

- Nicki

Posted 2014-01-06T14:49:25+0000  by THDCustomerCare
 
Not what you were looking for ? Try posting a question

Topic
Categories+