Sign In to join the community | Help
Heating & Cooling

Hampton Bay Cherokee Ceiling Fan not working (Lights work)

I have a Hampton Bay Cherokee ceiling fan with lights and remote. I just reinstalled it in another apartment I moved to recently.  The lights work perfectly, but the fan does not spin up, nor is there a motor sound. The blades spin freely when moved by hand. There are no switches or chains on this model as everything is controled through the remote. When I press the different fan buttons (low, med, hi, fan off) I can hear the sensor/switch clicking in response to the signal, but no action is taken, only when I press the light button.

 

The UPC number is UPC 845952000179

Hampton Bay Cherokee 56" Brushed Nickel Ceiling Fan SW1071-1

Not what you were looking for ? Try posting a question
Posted 2013-08-27T19:45:17+0000  by halo_ce halo_ce
 

New note:

 

I started to take it down from the ceiling. Removed the light, then removed the sensor. For testing sake I connected the white and black wire from the fan straight to the bulding's white and black wire (the blue stayed disconnected). Flipped the wall switch, nothing happened. I then connected the light pack to make sure the unit was getting power. The light did not turn on, but the fan started to spin! I officially have no clue what is going on with this thing.

Posted 2013-08-27T20:10:18+0000  by halo_ce

Hi, Halo_Ce!

We can help you with this. If the blades still move by hand, your problem is most likely just the capacitor. Please give our parts/tech support line a call at 877-262-7511 with that UPC, and they will be able to trouble shoot to confirm, then send parts as needed. Thanks for reaching out.

- Nicki

Posted 2013-08-30T14:14:31+0000  by THDCustomerCare
 
Not what you were looking for ? Try posting a question

Topic
Categories+