Sign In to join the community | Help
Heating & Cooling

Hampton Bay Cyprus Light Kit

Hello, 

 

I just installed a Hampton Bay Cyprus model (Model # CL11056 Store SKU # 220635).

 

This fan is unique as you notice that it's got two light sources- a light dome/globe above the fan blades, and it also has 3 cone style lights under the fan blades.

 

After my install the dome/globe light above the fan blades works, and the fan itself works (the blades spin perfectly). The issue is that the light kit with the 3 cone lights does not work. Those lights do not turn on (even though the power is obviously hooked up correctly or the dome light and blades wouldnt work).

 

The strange part about this is that the light kit appears to be the simplest part of the fan install, as there is a basic wiring "plug" that links the light kit to the fan base. When I installed the light kit it even "clicked" when joining the light kit plug to the fan base. Do I just have a faulty light kit? Or am I missing something?  I've installed at least a dozen fans in my life so I'm fairly familiar with the process. 

Not what you were looking for ? Try posting a question
Posted 2013-12-01T22:38:01+0000  by Hamilton Hamilton
 

Hello Hamilton and thank you for joining The Community.  We are glad that you are here.

 

Please contact our Hampton Bay team at 1-877-527-0313 and select option 2.  They will need your Store SKU # 220-635 and the UPC 845952-000353.  The team can help determine the source of the problem and get your ceiling fan and lights working properly.

 

Best wishes on your project and please keep us posted on your progress. 

 

Eileen script.png

Posted 2013-12-03T13:29:07+0000  by Eileen_HD_ATL
 
Not what you were looking for ? Try posting a question

Topic
Categories+