Sign In to join the community | Help
Heating & Cooling

Hampton Bay Fan lights up but won't turn

Does anyone know possible solutions for my Hampton Bay fan that doesn't spin but lights up?  I tried swapping out batteries from another remote to no avail...  Can it be fixed or does it need to be replaced?  Thanks!

Not what you were looking for ? Try posting a question
Posted 2012-02-23T02:54:56+0000  by shopper13 shopper13

Hey dsmooth.

 

You will not need your receipt, but the UPC # for the fan that you have will come in handy.  I will simply repeat what was posted on another thread you have, that your best bet for a solution is to call our Customer Support Team as shown below:

 

Customer Service.jpg

 

I hope this helps,

Newf.

 

.

Posted 2012-07-20T14:40:11+0000  by Chris_HD_CHI

UPC# 8082392735548

Posted 2012-08-21T23:17:55+0000  by FeliciaDinkins

Hello FeliciaDinkins.  Welcome to the Community!

 

Since you have the UPC for your fan, you are all set.  Please call the Hampton Bay Customer Service Team at the number listed below.

 

Customer Service.jpg

 

Thanks,

Newf.

 

.

Posted 2012-08-24T15:38:19+0000  by Chris_HD_CHI
I had this same problem.  In my case it turns out that the direction reversal switch in the side opposite the pull chain is the culprit.  When I wiggled it the fan came on.  Pushing up works in some case, pushing it to the side works in others.

Posted 2015-07-08T17:28:27+0000  by CharlesLloyd

I have a Reddinton II fan (Model CR552R1, UPC: 718167008486), controlled by remote, no pull chains on the unit.   Lights come with with remote, but, fan will not turn (no noise, but, I can hear a "click" each time I hit the reverse button on the remote).  Called in and was told they no longer make this fan, but, that the motor isn't broken, I just need a new receiver (mine is model FAN-2R, a yellow "ball" with two silver wings that come out to make contact with the housing).  Problem is, your warehouse no longer makes these?  I was told to contact Gulf Coast Fans for an authentic replacement receiver (FAN-2R).  I have since purchased TWO receivers (since the fist didn't solve my problem) both of which are identical to the one that came with the unit), but, neither one turns the fan on... lights still come on, but, fan won't turn (same as before, no humming or noise from the fan), but, I can hear a "clilck" when I hit the reverse button on the remote.

 

At this point, I believe the motor is burned out, but, even though the telephone prompt says have my TWELVE digit UPC code available, which I do (see above), two different agents tell me that they can't find my fan and that they need 13 digits?  What are my options? 


Posted 2015-12-28T22:19:09+0000  by LuisS
Not what you were looking for ? Try posting a question

Topic
Categories+