Sign In to join the community | Help
Electrical

Hi, today I installed a 70 Victoria ceiling fan by Hampton Bay

UPC # 845952000346 when I first turned on the power I pressed the light button on the remote, the fan started and the light hasn't ever turned on. I tried resetting it by turning the power off and now nothing works.

Some help would be greatly appreciated, I may have an over wattage issue with the lights and I'm not totally sure how to fix that but as I've said I'm not getting anything now.

Thanks
Not what you were looking for ? Try posting a question
Posted 2015-08-05T00:24:29+0000  by Needtofixit Needtofixit
 
The first couple of things that come to mind are have you checked your electrical connections and tried new the batteries in the remote?  While it should work out of the box, there is a remote reprogramming section in the manual.  Have you tried that?




Posted 2015-08-05T09:59:17+0000  by Adam444
According to the Home Depot's website the fan uses three 60 watt candelabra type bulbs that are included with the fan.  Did you use those or something else?
Posted 2015-08-05T10:05:51+0000  by Adam444
 
Not what you were looking for ? Try posting a question

Topic
Categories+