Sign In to join the community | Help
Install & Replace

One burner on GE Cooktop does not light

Hello, I have an old GE JGP336 sealed cooktop where the bottom right burner does not light. There is no clicking sound but you can smell and hear the gas coming out. I'm thinking this is the ignitor. Does anyone know how to replace the ignitor? Do I have to remove the burner bowl? If I have to remove the bowl, there are two rounded and rusted screws holding it down. How do I remove the screws? Thank you for you anyone's help.
Not what you were looking for ? Try posting a question
Posted 2012-09-04T23:55:19+0000  by dfsubscriptions dfsubscriptions
 

Hello dfsubscriptions, and welcome to the community!

 

Since you are not hearing the "clicking" when you turn the knobs to light the burner, it sounds like your Spark Module may have gone bad. I don't have  a service manual to give you step-by-step instructions on how to repair your cooktop so I recommend you contact GE to either obtain the Service Manual or better yet, have them do the repair, their contact info is below.

 

Parts & Accessories
1-877-959-8688
Monday–Friday: 8 a.m.–7 p.m. ET
Saturday: 8:30 a.m.–5 p.m. ET Sunday: Closed
geapplianceparts.com

 

GE Appliance Service
1-800-GECares (1-800-432-2737)
Monday–Friday: 7 a.m. – 10 p.m. ET
Saturday–Sunday: 8 a.m. – 6 p.m. ET

 

To remove those stubborn, hard to remove screws I suggest you try using the Pro Grabit, check out the video.

 

Posted 2012-09-07T15:46:11+0000  by Angelo_HD_CHI

I replaced the ignitor for the one burner and it worked once.  Afterwards, it won't work again.  The other three burners still work.

 

From what I read on GE's website and eHow, there is only one spark module for all 4 burners. it should only be changed if all the burners do not work, not if only one burner fails. so i'm a bit lost.

Posted 2012-09-10T21:56:14+0000  by dfsubscriptions

Discovered something new.  The not-working burner will lite if I lite another buner at the same time.  The not-working would click like normal and light as long as another burner is doing the same.  Does anyone have any idea why this is happening and how to fix it? is it the spark module?

 

thanks.

Posted 2012-09-12T06:24:51+0000  by dfsubscriptions
 
Not what you were looking for ? Try posting a question

Topic
Categories+