Sign In to join the community | Help
Tools & Hardware

Porter Cable air compressor

I just went to use my air PC2002 compressor and while the tank will fully charge (about 150), the Outlet Pressue Gauge (and pressure) is steadfast at 0.  I last used it about 6-8 weeks ago, have always kept it drained and in a dry environment. I tried fiddling with the regulator but nothing happens.  Am I missing something obvious that  neither the manual nor the Porter Cable site points out, or do I need to replace the regulator? I bought the unit in Sept/Oct of last year.

Not what you were looking for ? Try posting a question
Posted 2012-09-19T18:34:00+0000  by Easywriter Easywriter
 

Hello EasyWriter, and welcome to the community!

 

I'm sorry to hear your having a problem with the Porter-Cable compressor. It sounds like you did everything I would have suggested. The only thing left is to bring it into a Porter-Cable service center, and your compressor does have a 3-year warranty.

 

The 2nd link below allows you to enter your zipcode and it will find your nearest service center. You can also contact your nearest Home Depot, and ask for Tool Rental, they can also send it out for repair for you.

 

Warranty site: http://www.portercable.com/ServiceAndSupport/Warranties.aspx

 

Search for a Service Center: http://www.portercable.com/ServiceAndSupport/ServiceCenters.aspx

Posted 2012-09-20T14:37:28+0000  by Angelo_HD_CHI
 
Not what you were looking for ? Try posting a question

Topic
Categories+