Sign In to join the community | Help
Install & Replace

Windward II glass shade won't install

Hi, 
I purchased my Windward II from Home Depot last week. Installed it this morning. It's already the best fan I've ever had, but I can't get the glass shade on. It says to install by aligning the notched area with the matching area on the light cover... But all I have is three metal clips that are screwed against the top. Im assuming they are meant to catch the area of the shade and hold it, but they certainly do not. I tried for an hour and ended up slightly damaging the shade, but it refuses to go in (no part which holds it in is damaged). Any help? A video maybe?
Not what you were looking for ? Try posting a question
Posted 2017-02-20T05:35:27+0000  by Meanaverage Meanaverage
 
Well, looks like I got a reject with no nibs to hold the dome. That would explain my frustration. Dannng!
Posted 2017-02-20T07:23:31+0000  by Meanaverage

Hey Meanaverage,


Thanks for joining us here on the community.


Before you return the fan, make sure you have called Hampton Bay directly at the phone number shown below for further troubleshooting. 

Image result for hampton bay customer service

At least at my store, we haven't sold that fan in quite a while, so I can't physically look at it closer to see the design of it. So, contact Hampton Bay with the number above to see if there was a step you may have missed.

Let us know if you have any other questions,
Joseph
Posted 2017-02-20T19:17:57+0000  by Joseph_HD_ATL
 
Not what you were looking for ? Try posting a question

Topic
Categories+