Sign In to join the community | Help
Heating & Cooling

hampton bay ceiling fan light wont work

I have a hampton bay fan model (from sticker on top of motor) TDC1152BP5LKLRC, and the lights stopped working on them. The fan still works fine, just the light. I replaced the battery in the remote, changed the codes around, changed the bulbs, pulled the chain, hit diff switches and i just went and bought the hampton bay universal remote setup and same thing fan works light dosent. Any help is greatly welcome! thanks

Not what you were looking for ? Try posting a question
Posted 2011-05-31T02:29:31+0000  by edelbrock231 edelbrock231
If they dont wrk n ubhave a switch.  That u gotta push to turn lighta on hold it.  Theres a dimmer on it!   I had issues my lights werent bright enough. Turns out it was dimmed.   Who knew when u buy a house n dont know what ceiling fan options r 
Posted 2017-01-21T04:38:03+0000  by Cina1816

Wanted to bump this post with a new question with slightly different circumstances. We have a HB combination fan with light kit. Fan and light each have their own dedicated wall switches--no remote. A few days ago my wife reported that she turned on the light at the wall switch. There was a soft pop coming from the fan/light and the lights have quit working. I've replaced the bulb and disassembled the lower housing that contains the pull chain switch. No loose wires and no evidence of scorching in the switch itself.


I want to see if these symptoms, especially what may have popped if it wasn't a bulb, spark any ideas before I start doing further disassembly.


Thanks.


Larry

Posted 2017-03-08T23:46:33+0000  by FLLarry

Hi, I have the same problem as joonjhl. I have a Hampton Bay Windward II 54 in. and light goes on and off whenever it wants to.  Fan still works. I replaced the bulb with a 30W fluorescent bulb and still has the same problem. Remote control seems to be working, all other fan functions work fine. There is no dimmer switch.


Model No. 54-WWD

UPC#082392552954

Posted 2017-03-09T16:38:46+0000  by nimorales
One of the issues we ran into with the lights turning on and off randomly (with a remote controllted unit) is there's a chance it's set to the same frequency of one of your neighbor's TV remotes or fan remotes. There are tutorials online on how to change your fan's remote frequency. It involved us taking off the base of our unit.

We're now having an issue where the remote won't turn the lights off. The only way we can do it is by turning the light off at the switch. But there's times where we want the fan on but not the lights.

There's no chain on our fan. Like someone else in the thread, the fan was installed in the home before we bought it so we have no product information. The rest of the remote works fine-we can change the fan speed. We've tried changing the light bulb type and still no go. One of the original lights burned out and since we replaced it the remote won't work for lights. 
Posted 2017-03-21T06:28:14+0000  by Nomtastic
I bought a Hampton Bay fan at a garage sale.  Once it was installed it had the same problem as jebbo and FunnyMan - when turned on the fan would run, the lights would initially turn on, stay on briefly, and then turn off. After reading funnyMan's fix of swapping bulbs, I tried something similar.  I removed all the bulbs and one-by-one screwed them back in (trying to find a bad bulb).  The first, second, and third bulbs lit and stayed on.  However, when I screwed in the fourth bulb, they all flashed and turned off.  As a bit of background, the fan didn't have any bulbs in it when I purchased it.  I thought I needed additional light so I purchased 60W bulbs, even though the instructions said to only use 40W maximum.  I purchased some 40W bulbs and went through the one-by-one exercise again.  After installing the fourth 40W bulb they all stayed on.  The only thing I can guess is the fan could handle 3 60W bulbs, but the fourth 60W tripped a limit and shut everything down.  With the 40W bulbs everything continues to work.    
Posted 2017-04-14T01:16:43+0000  by JSTX
Not what you were looking for ? Try posting a question

Topic
Categories+